Resolved
This issue has been resolved. Please reach out to support@bolt.new if you are still experiencing any issues with your publishing hanging or getting stuck.
Monitoring
We've deployed a fix and are monitoring the solution.
Identified
We've identified and are working on a fix for the issue where publishing can hang on "Publishing your site, this will just take a moment…" and never finish. This is intermittent
and affects individual projects, so your other projects may publish normally.
In the meantime, if a publish gets stuck, refresh the page and click Publish again straight away. That should publish your website in most cases.
Investigating
We are investigating an issue where some users may experience publishing hanging/getting stuck with "Publishing your site, this will just take a moment..."