Resolved
This issue has been resolved.
Monitoring
We've seen improvement in our backend systems that coincides with Cloudflare's reported resolution on their status page; we are monitoring the situation for further issues.
Investigating
We're currently investigating an issue where users are unable to save project files. Early indication is that it could be related to reported cloudflare network issues.