Resolved
This issue has been resolved.
Monitoring
The issue appears to have been related to a third party provider, we are monitoring the situation but functionality to users should be properly restored at this time.
Investigating
We're currently investigating an issue where users are reporting "Failed to save project" errors.