Resolved
This issue has been resolved.
Monitoring
We've deployed the permanent fix for the GitHub disconnect issue in the Bolt service. The update addresses the UI regression that caused some user projects to appear disconnected from GitHub, even though syncing and importing worked in the background.
Investigating
Some users may see their GitHub integration appearing as disconnected from their Bolt project after refreshing, even if the project was imported from or connected to GitHub. GitHub syncing and importing continue to function normally.
We are actively working on a fix and will provide updates as we learn more.